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Troubleshooting

This page will help you overcome the most common problems that may occur during the installation and configuration of the HaloCORE solution, as listed below.

As the first step in troubleshooting, make sure that your HaloCORE version is up to date. Each release of HaloCORE adds new features and fixes many problems. Installing the latest version may clear any problems without the need for further troubleshooting.

Cannot Continue Installation 

Symptom 

Error message: A newer version of Secude HaloENGINE Service is already installed! Cannot continue the installation. 

Background

HaloENGINE Service is already installed on the computer.  

Probable Cause

The user tries to install an older version of HaloENGINE Service on the computer where a newer version of HaloENGINE Service is already installed. The installer does not allow downgrade installation. For example, from the 2.1 to 2.0 version.  

Workaround

You may have to uninstall and install the lower version or upgrade the installation to the latest version.

Server Communication Failed/No Active Server Found

Symptom 

Error message: SOAP:1.023 SRT: Processing error in Internet Communication Framework: (“ICF Error when receiving the response: ICM_HTTP_SSL_ERROR")

Background

The above-mentioned error message appears while SAP tries to communicate with HaloENGINE through the logical port.

Probable Cause

  1. Expired certificates have been used.

  2. Incorrect details were entered while creating the HaloENGINE certificate.

  3. HaloENGINE certificate (HaloENGINEServer.cer) is not installed in STRUST.

  4. SAP instance certificate is not installed in the HaloENGINE Admin Portal.

Corrective Action

  1. Case 1: Verify the expiry date of the certificate which is installed in both HaloENGINE and in transaction STRUST.

    Expired System certificate.png

    Expired Certificate in HaloENGINE

    Expired certificate in SAP.png

    Expired Certificate in STRUST

  2. Update the valid certificate if the certificate has expired.

  3. Case 2: Enter the correct Subject Alternate Name (DNS) into the HaloENGINE certificate and update it. If you are communicating with the HaloENGINE over HTTPS, the hostname entered in the field Computer Name of Access URL on page Transport Binding in transaction SOAMANAGER must match that stored in the server's certificate. Otherwise, the connection will fail with ICM_HTTP_SSL_ERROR.

    Creating a server certificate.png

    HaloENGINE Certificate

  4. Case 3: Check whether the HaloENGINE certificate is installed in STRUST; if not, import the valid HaloENGINEServer.cer certificate.

  5. Case 4: Ensure that the valid SAP system's certificate (SSL Client (Standard)) is installed in the HaloENGINE Admin Portal.

Could not Forward Logs to HaloENGINE

Symptom 

Error message: SOAP:1.023 SRT: Processing error in Internet Communication Framework: (“ICF Error when receiving the response: ICM_HTTP_SSL_ERROR") Error when processing Web service call.

Error in Resend queued log entries

Background

The above-mentioned error message appears when you execute the program /SECUDESD/RESEND_LOG to resend the queued log entries.

Probable Cause

  1. No logical port was found for consumer proxy /SECUDESD/CO_AUDIT.

  2. Incorrect /no logical port is entered in transaction /SECUDESD/CNF_LOG for the field Logical Port.

Corrective Action

  1. Case 1: Create a valid logical port with consumer proxy /SECUDESD/CO_AUDIT.

  2. Case 2: Check and enter the correct name of the logical port.

Error was not listed here

If you encounter an error or problem that is not listed in this troubleshooting section, we'd like to hear about it. Please send an email to support@secude.com with the details of the error you encountered. 

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